藤 吾郎 > Acme-RequireModule > Acme::RequireModule

Download:
Acme-RequireModule-0.01.tar.gz

Dependencies

Annotate this POD

View/Report Bugs
Module Version: 0.01   Source  

NAME ^

Acme::RequireModule - Extends require() to accept module names

VERSION ^

This document describes Acme::RequireModule version 0.01.

SYNOPSIS ^

        use Acme::RequireModule; # This is a lexical pragma.

        foreach my $module qw(Foo Bar Baz){
                require $module; # Yes, we can!
        }

DESCRIPTION ^

There are too many ways to load modules :(

I wish require() accepted module names!

INTERFACE ^

DEPENDENCIES ^

Perl 5.10.0 or later, and a C compiler.

BUGS ^

No bugs have been reported.

Please report any bugs or feature requests to the author.

SEE ALSO ^

perlfunc.

AUTHOR ^

Goro Fuji <gfuji(at)cpan.org>.

LICENSE AND COPYRIGHT ^

Copyright (c) 2009, Goro Fuji <gfuji(at)cpan.org>. Some rights reserved.

This library is free software; you can redistribute it and/or modify it under the same terms as Perl itself.

syntax highlighting: