View on
MetaCPAN
Barry King > Apache-Wyrd > Apache::Wyrd::BrowserSwitch

Download:
Apache-Wyrd-0.98.tar.gz

Dependencies

Annotate this POD

View/Report Bugs
Module Version: 0.98   Source  

NAME ^

Apache::Wyrd::BrowserSwitch - Enclose a set of browser-versioned blocks

SYNOPSIS ^

  <BASENAME::BrowserSwitch>
    <BASENAME::Version test="IE">
      .. version for MSIE ..
    </BASENAME::VERSION>
    <BASENAME::Version tests="Gecko, Safari">
      .. version for NS & Safari ..
    </BASENAME::VERSION>
    <BASENAME::Version test="Lynx">
      .. version for Lynx ..
    </BASENAME::VERSION>
    <BASENAME::Version test="Google" matchstring="Googlebot">
      .. version for Google ..
    </BASENAME::VERSION>
  </BASENAME::BrowserSwitch>

DESCRIPTION ^

Encloses a set of Version wyrds for a browser-dependent section of HTML.

HTML ATTRIBUTES

NONE

FLAGS

NONE

PERL METHODS

(format: (returns) name (arguments after self))

(scalar) _add_version (void)

Internal method for Version wyrds to register themselves to their parent.

BUGS/CAVEATS ^

Reserves the setup and _generate_output methods.

AUTHOR ^

Barry King <wyrd@nospam.wyrdwright.com>

SEE ALSO ^

Apache::Wyrd

General-purpose HTML-embeddable perl object

Apache::Wyrd::Version

Container for a browser-dependent version of a block of HTML

LICENSE ^

Copyright 2002-2007 Wyrdwright, Inc. and licensed under the GNU GPL.

See LICENSE under the documentation for Apache::Wyrd.

syntax highlighting: