Hans Dieter Pearcey > CatalystX-MooseComponent > CatalystX::MooseComponent

Download:
CatalystX-MooseComponent-0.004.tar.gz

Dependencies

Annotate this POD

View/Report Bugs
Module Version: 0.004   Source  

NAME ^

CatalystX::MooseComponent - Ensure your Catalyst component isa Moose::Object

VERSION ^

version 0.004

SYNOPSIS ^

  package MyApp::Controller::Foo;

  use Moose;
  BEGIN { extends 'Catalyst::Controller' }
  use CatalystX::MooseComponent;

  # My::CatalystComponent now isa Moose::Object

DESCRIPTION ^

This module lets you write Catalyst components that are Moose objects without worrying about whether Catalyst::Component is Moose-based or not (Catalyst 5.7 vs. 5.8). It handles pulling in global application configuration and adding Moose::Object to your component's superclasses.

METHODS ^

init_meta

Called automatically by import to set up the proper superclasses and wrap new().

AUTHOR ^

  Hans Dieter Pearcey <hdp@cpan.org>

COPYRIGHT AND LICENSE ^

This software is copyright (c) 2009 by Hans Dieter Pearcey.

This is free software; you can redistribute it and/or modify it under the same terms as perl itself.

NOTE ^

Catalyst-Runtime 5.71001 obsoletes this module. Depend on it instead.

CREDIT ^

Based on code from Catalyst::Controller::ActionRole by Florian Ragwitz <rafl@debian.org>.

syntax highlighting: