Randy Stauner > Dist-Zilla-Config-Slicer > Dist::Zilla::PluginBundle::ConfigSlicer

Download:
Dist-Zilla-Config-Slicer-0.200.tar.gz

Dependencies

Annotate this POD

Website

CPAN RT

Open  0
View/Report Bugs
Module Version: 0.200   Source  

NAME ^

Dist::Zilla::PluginBundle::ConfigSlicer - Load another bundle and override its plugin configurations

VERSION ^

version 0.200

SYNOPSIS ^

  ; in your dist.ini:

  [@ConfigSlicer]
  -bundle = @Classic
  -remove = PodVersion
  -remove = Manifest
  option = for_classic
  ManifestSkip.skipfile = something.weird

DESCRIPTION ^

This plugin bundle actually wraps and modifies another plugin bundle. It extends @Filter and additionally consumes Dist::Zilla::Role::PluginBundle::Config::Slicer so that any plugin options will be passed in.

This way you can override the plugin configuration for any bundle that doesn't consume Dist::Zilla::Role::PluginBundle::Config::Slicer as if it did!

SEE ALSO ^

AUTHOR ^

Randy Stauner <rwstauner@cpan.org>

COPYRIGHT AND LICENSE ^

This software is copyright (c) 2011 by Randy Stauner.

This is free software; you can redistribute it and/or modify it under the same terms as the Perl 5 programming language system itself.

syntax highlighting: