Léon Brocard > JSON-XS-VersionOneAndTwo > JSON::XS::VersionOneAndTwo

Download:
JSON-XS-VersionOneAndTwo-0.31.tar.gz

Dependencies

Annotate this POD

View/Report Bugs
Module Version: 0.31   Source  

NAME ^

JSON::XS::VersionOneAndTwo - Support versions 1 and 2 of JSON::XS

SYNOPSIS ^

  use JSON::XS::VersionOneAndTwo;
  my $data = { 'three' => [ 1, 2, 3 ] };

  # use JSON::XS version 1.X style
  my $json1 = to_json($data);
  my $data1 = from_json($json1);
  
  # or use JSON::XS version 2.X style
  my $json2 = encode_json($data);
  my $data2 = decode_json($json2);

DESCRIPTION ^

JSON::XS is by far the best JSON module on the CPAN. However, it changed its API at version 2.01. If you have to maintain code which may be run on systems with either version one or two then this is a bit of a pain. This module takes the pain away without sacrificing performance.

AUTHOR ^

Leon Brocard <acme@astray.com>.

COPYRIGHT ^

Copyright (C) 2008, Leon Brocard

This module is free software; you can redistribute it or modify it under the same terms as Perl itself.

syntax highlighting: