Ingy döt Net > Module-Install-RequiresList > Module::Install::RequiresList

Download:
Module-Install-RequiresList-0.10.tar.gz

Dependencies

Annotate this POD

CPAN RT

New  1
Open  0
View/Report Bugs
Module Version: 0.10   Source  

SYNOPSIS ^

In your Makefile.PL:

    use inc::Module::Install;
    ...
    requires_list;
    ...

From the command line:

    > perl Makefile.PL
    > make requires-list

DESCRIPTION ^

This module adds a target to your Makefile for listing the modules required.

The report is broken into sections: Required, Recommended, Build Requires, and Author Requires.

For each module listed, the report prints 3 versions: the version you are requesting, your installed version and the CPAN version.

syntax highlighting: