Curtis "Ovid" Poe > Package-Butcher > Package::Butcher::Inflator

Download:
Package-Butcher-0.02.tar.gz

Dependencies

Annotate this POD

View/Report Bugs
Module Version: 0.02   Source  

NAME ^

Package::Butcher::Inflator - For internal use only

VERSION ^

Version 0.02

SYNOPSIS ^

    use Package::Butcher::Inflator;
    my $inflate = Package::Butcher::Inflator->new(
        { foo => { bar => { baz => sub { 'whee! } } } },
    );
    print $inflate->foo->bar->baz; # whee!

AUTHOR ^

Curtis 'Ovid' Poe, <ovid at cpan.org>

BUGS ^

Please report any bugs or feature requests to bug-package-butcher at rt.cpan.org, or through the web interface at http://rt.cpan.org/NoAuth/ReportBug.html?Queue=Package-Butcher. I will be notified, and then you'll automatically be notified of progress on your bug as I make changes.

SUPPORT ^

You can find documentation for this module with the perldoc command.

    perldoc Package::Butcher::Inflator

You can also look for information at:

ACKNOWLEDGEMENTS ^

Marcel Gruenauer <marcel@cpan.org>, the author of Hash::Inflator

LICENSE AND COPYRIGHT ^

Copyright 2011 Curtis 'Ovid' Poe.

This program is free software; you can redistribute it and/or modify it under the terms of either: the GNU General Public License as published by the Free Software Foundation; or the Artistic License.

See http://dev.perl.org/licenses/ for more information.

syntax highlighting: