Karen Etheridge > Pod-Weaver-Plugin-Encoding > Pod::Weaver::Plugin::Encoding

Download:
Pod-Weaver-Plugin-Encoding-0.03.tar.gz

Dependencies

Annotate this POD

Website

View/Report Bugs
Module Version: 0.03   Source  

NAME ^

Pod::Weaver::Plugin::Encoding - (DEPRECATED) Add an encoding command to your POD

VERSION ^

version 0.03

SYNOPSIS ^

In your weaver.ini:

  [-Encoding]

or

  [-Encoding]
  encoding = koi8-r

DESCRIPTION ^

This section will add an =encoding command like

  =encoding UTF-8

to your POD.

ATTRIBUTES ^

encoding

The encoding to declare in the =encoding command. Defaults to UTF-8.

METHODS ^

finalize_document

This method prepends an =encoding command with the content of the encoding attribute's value to the document's children.

Does nothing if the document already has an =encoding command.

SEE ALSO ^

Pod::Weaver::Section::Encoding is very similar to this module, but expects the encoding to be specified in a special comment within the document that's being woven.

Pod::Weaver::Plugin::SingleEncoding can be considered the successor to this module, and is a core part of Pod::Weaver version 4. It is contained within [@Default], and you should be using that plugin rather than this one.

AUTHOR ^

Florian Ragwitz <rafl@debian.org>

CONTRIBUTORS ^

COPYRIGHT AND LICENSE ^

This software is copyright (c) 2010 by Florian Ragwitz.

This is free software; you can redistribute it and/or modify it under the same terms as the Perl 5 programming language system itself.

syntax highlighting: