The Perl Toolchain Summit needs more sponsors. If your company depends on Perl, please support this very important event.
# Copyright 2010, 2011, 2012, 2013, 2014 Kevin Ryde

# This file is part of Math-PlanePath.
#
# Math-PlanePath is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License as
# published by the Free Software Foundation; either version 3, or (at
# your option) any later version.
#
# Math-PlanePath is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with Math-PlanePath.  If not, see <http://www.gnu.org/licenses/>.


# Build-Depends could have the "maximum_tests" modules from META.yml
# for more tests, but they're optional author tests really and would
# just make the build tools drag in more stuff.

Source: libmath-planepath-perl
Section: perl
Priority: optional
Build-Depends: cdbs, debhelper (>= 5)
Maintainer: Kevin Ryde <user42_kevin@yahoo.com.au>
Standards-Version: 3.9.6
Homepage: http://user42.tuxfamily.org/math-planepath/index.html
Bugs: mailto:user42_kevin@yahoo.com.au

Package: libmath-planepath-perl
Architecture: all
Depends: perl (>= 5.004), libconstant-perl (>= 1.02) | perl (>= 5.6), libmath-libm-perl, libscalar-list-utils-perl | perl (>= 5.8), ${perl:Depends}, ${misc:Depends}
Description: Mathematical paths through the plane
 Perl code to generate some paths through the 2-D X,Y plane, mainly
 integer oriented, and including
 .
  * Square numbering of Ulam's spiral
  * Pentagonal, hexagonal, heptagonal spirals
  * Pyramid and triangular spirals and rows
  * An infinite knight's tour
  * Vogel's sunflower floret (and variations)
  * Sacks' quadratic spiral
  * Spiral of Theodorus
  * Peano, Hilbert and Z-Order
  * Gosper's flowsnake
  * Koch curve and quadric curve
  * Sierpinski triangle
  * Dragon curves
  * Pixellated rings, and by hypotenuse distance
  * Trees of rationals and Pythagorean triples
  * Some complex base related patterns