Brendan Byrd > Dist-Zilla-PluginBundle-Prereqs-0.91 > Dist::Zilla::Plugin::MinimumPrereqs

Download:
Dist-Zilla-PluginBundle-Prereqs-0.91.tar.gz

Dependencies

Annotate this POD

Website

View/Report Bugs
Module Version: 0.91   Source   Latest Release: Dist-Zilla-PluginBundle-Prereqs-0.93

NAME ^

Dist::Zilla::Plugin::MinimumPrereqs - Adjust blank prereqs to use the lowest version available

SYNOPSIS ^

    ; ...other Prereq plugins...
    [MinimumPrereqs]
    minimum_year = 2008  ; default

DESCRIPTION ^

This plugin will scan for any "blank" pre-requirement (ie: Module => 0), search MetaCPAN for the lowest version that was released at least within minimum_year, and fix the prereq to contain that mimimum version.

Why bother?

Put your money where your mouth is. If you say that you can support any version, like Moose v0.01, then actually commit to it.

What's that? You don't actually think it'll work on the very first version of Moose? Then at least commit to something that was released in year 20XX.

Why not just use LatestPrereqs?

Some users prefer to download as little from CPAN as they need to, and keep their Perl requirements in the same place as their OS requirements. For example, Debian's apt system has thousands of Perl modules, with all of the proper requirements and dependencies, thanks to the Debian Perl Group's work to translate those Perl modules to Debian packages. This keeps OS dependencies clean and makes upgrades seemless.

By maintaining accurate minimum prereqs, you can find a good happy medium between making sure your module works for the right version ranges, and not promoting overly restrictive version requirements.

OPTIONS ^

minimum_year

This is the lowest release year it will accept to add as a minimum requirement. For example, if you have a Moose requirement as Moose => 0, under the default year of 2008, it will change this to Moose => 0.34, which was released in January 21, 2008.

SEE ALSO ^

AVAILABILITY ^

The project homepage is https://github.com/SineSwiper/Dist-Zilla-PluginBundle-Prereqs/wiki.

The latest version of this module is available from the Comprehensive Perl Archive Network (CPAN). Visit http://www.perl.com/CPAN/ to find a CPAN site near you, or see https://metacpan.org/module/Dist::Zilla::PluginBundle::Prereqs/.

AUTHOR ^

Brendan Byrd <BBYRD@CPAN.org>

COPYRIGHT AND LICENSE ^

This software is Copyright (c) 2012 by Brendan Byrd.

This is free software, licensed under:

  The Artistic License 2.0 (GPL Compatible)
syntax highlighting: