Brian Cassidy > Config-Any-0.24 > Config::Any::Base

Download:
Config-Any-0.24.tar.gz

Dependencies

Annotate this POD

CPAN RT

New  2
Open  4
View/Report Bugs
Source  

NAME ^

Config::Any::Base - Base class for loaders

DESCRIPTION ^

This is a base class for all loaders. It currently handles the specification of dependencies in order to ensure the subclass can load the config file format.

METHODS ^

is_supported( )

Allows us to determine if the file format can be loaded. The can be done via one of two subclass methods:

You can specify a module version by passing an array reference in the return.

    sub requires_all_of { [ 'My::Module', '1.1' ], 'My::OtherModule' }

Lack of specifying these subs will assume you require no extra modules to function.

AUTHOR ^

Brian Cassidy <bricas@cpan.org>

COPYRIGHT AND LICENSE ^

Copyright 2008-2009 by Brian Cassidy

This library is free software; you can redistribute it and/or modify it under the same terms as Perl itself.

SEE ALSO ^

syntax highlighting: