Glenn Fowler > Dist-Zilla-PluginBundle-CEBJYRE-0.4.0 > Dist::Zilla::PluginBundle::CEBJYRE

Download:
Dist-Zilla-PluginBundle-CEBJYRE-0.4.0.tar.gz

Dependencies

Annotate this POD

View/Report Bugs
Module Version: 0.4.0   Source  

NAME ^

Dist::Zilla::PluginBundle::CEBJYRE - My default dzil plugins

VERSION ^

version 0.4.0

DESCRIPTION ^

Using this bundle is equivalent to:

  [AutoPrereqs]
  [PkgVersion]
  [PodWeaver]
  [PodCoverageTests]
  [PodSyntaxTests]
  [NextRelease]
  [CheckPrereqsIndexed]
  [MetaJSON]
  [@Filter]
  -bundle = @Basic
  -remove = MetaYAML
  [@Git]

where the @Filter bundle is the @Basic bundle with the MetaYAML plugin stripped out. Configurations options may be passed into the Git bundle by prefacing the usual option names with git_. Likewise prerequisites generated by AutoPrereqs may be disregarded with prereq_skip.

For example:

  [@CEBJYRE]
  git_push_to = github
  prereq_skip = Not::A::Real::Prereq

METHODS ^

configure

See Dist::Zilla::Role::PluginBundle::Easy.

AUTHOR ^

Glenn Fowler <cebjyre@cpan.org>

COPYRIGHT AND LICENSE ^

This software is copyright (c) 2011 by Glenn Fowler.

This is free software; you can redistribute it and/or modify it under the same terms as the Perl 5 programming language system itself.

syntax highlighting: