Christopher H. Laco > Handel-1.00014 > Handel::Manual::Requirements

Download:
Handel-1.00014.tar.gz

Annotate this POD

CPAN RT

New  1
Open  0
View/Report Bugs
Source  

NAME ^

Handel::Manual::Requirements - What you need to install to use Handel.

DESCRIPTION ^

This page lists the known requirements recommended software needed to use Handel.

REQUIREMENTS ^

Prerequisites

The following modules are required for Handel to work properly. Older versions may work fine, but these are the versions I have installed and verified to work correctly. If you have older versions and all tests pass, send me an email and I'll lower the version requirements.

DBIx::Class

Version 0.08 or greater.

DBIx::Class::UUIDColumns

Version 0.01 or greater.

DBIx::Class::Validation

Version 0.01 or greater.

Class::Accessor::Grouped

Version 0.02 or greater.

Class::ISA

Version 0.32 or greater.

Class::Inspector

Version 0.16 or greater.

Clone

Version 0.20 or greater.

Data::Currency

Version 0.03 or greater.

Error

Version 0.14 or greater.

Locale::Maketext

Version 1.06 or greater.

Module::Pluggable

Version 2.95 or greater.

Module::Starter

Version 1.42 or greater.

This is only used for the quick start module creation. IF you don't plan on using that, you can ignore this requirement.

Scalar::Util

Version 0.13 or greater with weaken support.

Tie::Hash

Version 1.01 or greater.

DateTime

Version 0.31 or greater.

DateTime::Format::MySQL

Version 0.04 or greater.

This is used in the bulk of core module tests with SQLite. IF you are using another database like Postgres, you should install the appropriate module for that database.

NEXT

This is only used in Handel::Compat.

SQL::Translator

Version 0.08 or greater. This is used by DBIC and the quick start code to install the schema to a db. You can ignore this requirement if you are not going to use the quick start.

Locale::Currency::Format

Version 1.22 or greater.

This module allows all prices to be formatted to specific currency codes and formats.

Finance::Currency::Convert::WebserviceX

Version 0.03 or greater.

This module allows all prices to be converted from one currency to another.

Locale::Currency

Version 2.07 or greater.

This module allows all conversion and currency codes to be verified as real 3 letter ISO currency codes.

Getopt::Long

This is included in perl 5.8. It is used by the quick start code.

Pod::Usage

This is included in perl 5.8. It is used by the quick start code.

FormValidator::Simple

Version 0.17 or greater.

This module is only required if you plan on using the generated scaffolding code from the supplied Catalyst Controller/Model Helpers.

Optional Modules

The following modules are not required for Handel to run, although some features may be unavailable without them.

AxKit

Version 1.61 or greater.

AxKit is only required if you plan on using Handel within XSP pages using the supplied taglibs.

Template Toolkit

Version 2.07 or greater.

Template ToolKit is only required if you plan on using Handel within TT2 based websites using the supplied TT plugins.

Catalyst::Runtime

Version 5.7007 or greater.

Catalyst is only required if you plan on using the supplied Catalyst Cart/Order models withing a Catalyst app.

Catalyst::Devel

Version 1.0 or greater.

Catalyst::Devel is only required if you plan on using the supplied Catalyst Helpers to generate scaffolding or started code.

HTML::FiillInForm

Version 1.05 or greater.

This module is only required if you plan on using the generated scaffolding code from the supplied Catalyst Controller/Mode Helpers.

YAML

Version 0.58 or greater.

This module is only required if you plan on using the generated scaffolding code from the supplied Catalyst Controller/Mode Helpers.

Test Modules

The following modules are only required for the test suite when running make test.

Apache::Test

Version 1.27 or greater.

Apache::Test is used to test the AxKit XSP taglib modules.

Test::More

Version 0.61 or greater.

Earlier Test::More modules may have an issue with running the number of tests in this dist with 'command line too long' type errors.

Pod::Coverage

Version 0.14 or greater.

The pod coverage tests may fail complaining about missing pod for methods if Pod::Coverage < 0.14 is installed. This is due to certain syntax variations of the pod with escaped gt/lt. I may just alter the pod and bump this version down if there is enough feedback to do so.

Test::Pod

Version 1.00 or greater.

Test::Pod 1.00 added the all_pod_files_ok() method which makes my life easier. :-)

Test::Pod::Coverage

Version 1.04 or greater.

Test::Pod::Coverage 1.04 was made taint safe, and we run the tests with -wT like good girls and boys.

Test::Strict

Version 0.01 or greater.

This keeps me honest and makes sure I always use strict.

Test::Spelling

Version 0.10 or greater.

I can't type, or spell. This keeps the pod somewhat readable.

Test::NoTabs

Version 0.01 or greater.

Tabs are bad, m'kay? This keeps me honest.

Test::Perl::Critic

Version 0.08 or greater.

Yet another test to keep my code somewhat honest.

AUTHOR ^

    Christopher H. Laco
    CPAN ID: CLACO
    claco@chrislaco.com
    http://today.icantfocus.com/blog/
syntax highlighting: