Yo-An Lin (林佑安) > VIM-Packager-2010.03218 > VIM::Packager::MetaReader

Download:
VIM-Packager-2010.03218.tar.gz

Dependencies

Annotate this POD

CPAN RT

New  1
Open  0
View/Report Bugs
Source  

Synopsis ^

Generic VIM Meta file format

    =name            new_plugin

    =abstract        vim plugin blah blah blah

    =author          Cornelius (cornelius.howl@gmail.com)

    =version_from    plugin/new_plugin.vim   # extract version infomation from this file

    =type            syntax

    =script_id       [script id on vim.org]    # for uploading script to vim.org

    =dependency

        autocomplpop.vim > 0.3
        rainbow.vim      >= 1.2

        libperl.vim
            | autoload/libperl.vim | http://....../..././.../libperl.vim
            | autoload/std.vim | http://....../..././.../std.vim

        cpan.vim > 0
            git://github.com/c9s/cpan.vim.git  # install from git repository

    =libpath .

    =script

        bin/parser
        bin/template_generator

    =repository git://....../

Description ^

Constant ^

META_FILES

available metafile names: VIMMETA, META, VIMMETA.yml

Functions ^

new

meta

read_metafile

read_metafile function tries to find available vim meta file and parse meta file into hashref.

return meta information in hashref.

find_meta_file

find_meta_file function tries to find available vim meta file

return the filename of vim meta file (string)

    # XXX: check for mandatory meta info
    my $fall;
    my $meta = $class->meta;
    for ( qw(name author version type vim_version) ) {
        if( ! defined $meta->{ $_ } ) {
            print STDOUT "META: column '$_' is required. ";
            $fall = 1;
        }
    }
    die if $fall;

__install_dirs

if you don't like vimlib/

syntax highlighting: