Daisuke Maki > Module-Install-Any-Moose-0.00003 > Module::Install::Any::Moose

Download:
Module-Install-Any-Moose-0.00003.tar.gz

Dependencies

Annotate this POD

CPAN RT

Open  1
View/Report Bugs
Module Version: 0.00003   Source  

NAME ^

Module::Install::Any::Moose - Any::Moose Support For Module::Install

SYNOPSIS ^

    use inc::Module::Install;

    # your usual stuff...

    # This will ask the user if MouseX::AttributeHelpers should be installed
    requires_any_moose 'X::AttributeHelpers'; 

    WriteAll;

METHODS ^

requires_any_moose(%opts)

Speicifies Mouse/Moose as requirements. See the next entry for details on %opts

requires_any_moose($module, %opts)

Specifies Mouse/Moose extensions as requirements.

$module should be a module name fragment, like '::Util::TypeConstraints' or 'X::AttributeHelpers'.

%opts may contain the following values:

prefer $prefix

Specify 'Moose' or 'Mouse'. This will tell Module::Install::Any::Moose to check for $prefix's version as the requirement. The other one would be an optional module.

The default is Mouse.

moose $version

Specify the Moose alternative's minimum version.

mouse $version

Specify the Mouse alternative's minimum version.

As an example, the following would require MooseX::AttributeHelpers 0.13, and MouseX::AttributeHelpers as an optional dependency:

    requires_any_moose 'X::AttributeHelpers' => (
        prefer => 'Moose',
        moose => '0.13',
        mouse => '0.01'
    );

AUTHOR ^

Daisuke Maki daisuke@endeworks.jp

LICENSE ^

This program is free software; you can redistribute it and/or modify it under the same terms as Perl itself.

See http://www.perl.com/perl/misc/Artistic.html

syntax highlighting: