Jesse Luehrs > Dist-Zilla-Plugin-PerlVersionPrereqs-0.01 > Dist::Zilla::Plugin::PerlVersionPrereqs

Download:
Dist-Zilla-Plugin-PerlVersionPrereqs-0.01.tar.gz

Dependencies

Annotate this POD

Website

View/Report Bugs
Module Version: 0.01   Source  

NAME ^

Dist::Zilla::Plugin::PerlVersionPrereqs - set additional prereqs for older perls

VERSION ^

version 0.01

SYNOPSIS ^

  ; dist.ini
  [PerlVersionPrereqs / 5.010]
  Perl6::Say = 0

DESCRIPTION ^

When perl gets new features, oftentimes they are reimplemented as CPAN modules for earlier perls which don't have those features. It's a bit silly to unconditionally depend on those backwards compatiblity modules if they are just going to do nothing at all on the version of perl you're installing them on though, so this module allows you to specify that certain dependencies aren't required on perls newer than a certain version.

NOTE: This plugin only works on dists that are using the default [MakeMaker] plugin.

BUGS ^

No known bugs.

Please report any bugs through RT: email bug-dist-zilla-plugin-perlversionprereqs at rt.cpan.org, or browse to http://rt.cpan.org/NoAuth/ReportBug.html?Queue=Dist-Zilla-Plugin-PerlVersionPrereqs.

SEE ALSO ^

Dist::Zilla::Plugin::OSPrereqs

This plugin is based heavily on code from the [OSPrereqs] plugin.

SUPPORT ^

You can find this documentation for this module with the perldoc command.

    perldoc Dist::Zilla::Plugin::PerlVersionPrereqs

You can also look for information at:

AUTHOR ^

Jesse Luehrs <doy@tozt.net>

COPYRIGHT AND LICENSE ^

This software is Copyright (c) 2013 by Jesse Luehrs.

This is free software, licensed under:

  The MIT (X11) License
syntax highlighting: