Jesse Luehrs > Moose-2.0604 > Moose::Meta::Role::Method::Required

Download:
Moose-2.0604.tar.gz

Dependencies

Annotate this POD

CPAN RT

New  10
Open  39
Stalled  5
View/Report Bugs
Module Version: 2.0604   Source   Latest Release: Moose-2.1210

NAME ^

Moose::Meta::Role::Method::Required - A Moose metaclass for required methods in Roles

VERSION ^

version 2.0604

DESCRIPTION ^

INHERITANCE ^

Moose::Meta::Role::Method::Required is a subclass of Class::MOP::Object. It is not a subclass of Moose::Meta::Role::Method since it does not provide an implementation of the method.

METHODS ^

Moose::Meta::Role::Method::Required->new(%options)

This creates a new type constraint based on the provided %options:

  • name

    The method name. This is required.

$method->name

Returns the required method's name, as provided to the constructor.

BUGS ^

See "BUGS" in Moose for details on reporting bugs.

AUTHOR ^

Moose is maintained by the Moose Cabal, along with the help of many contributors. See "CABAL" in Moose and "CONTRIBUTORS" in Moose for details.

COPYRIGHT AND LICENSE ^

This software is copyright (c) 2012 by Infinity Interactive, Inc..

This is free software; you can redistribute it and/or modify it under the same terms as the Perl 5 programming language system itself.

syntax highlighting: