Dave Rolsky > Moose-Policy > Moose::Policy

Download:
Moose-Policy-0.05.tar.gz

Dependencies

Annotate this POD

CPAN RT

New  1
Open  3
View/Report Bugs
Module Version: 0.05   Source  

NAME ^

Moose::Policy - Moose-mounted police

SYNOPSIS ^

  package Foo;

  use Moose::Policy 'Moose::Policy::FollowPBP';
  use Moose;

  has 'bar' => (is => 'rw', default => 'Foo::bar');
  has 'baz' => (is => 'ro', default => 'Foo::baz');

  # Foo now has (get, set)_bar methods as well as get_baz

DEPRECATION NOTICE ^

Moose::Policy is deprecated.

MooseX::FollowPBP replaces the Moose::Policy::FollowPBP module. The other policies included in this distribution do not yet have standalone MooseX modules, as of November, 2010.

This module has not passed its tests since Moose 1.05, and will probably not be fixed.

DESCRIPTION ^

This module allows you to specify your project-wide or even company-wide Moose meta-policy.

Most all of Moose's features can be customized through the use of custom metaclasses, however fiddling with the metaclasses can be hairy. Moose::Policy removes most of that hairiness and makes it possible to cleanly contain a set of meta-level customizations in one easy to use module.

This is still an release of this module and it should not be considered to be complete by any means. It is very basic implemenation at this point and will likely get more feature-full over time, as people request features. So if you have a suggestion/need/idea, please speak up.

What is a meta-policy?

A meta-policy is a set of custom Moose metaclasses which can be used to implement a number of customizations and restrictions on a particular Moose class.

For instance, Moose::Policy::SingleInheritence enforces that all specified Moose classes can only use single inheritance. It does this by trapping the call to superclasses on the metaclass and only allowing you to assign a single superclass.

The Moose::Policy::FollowPBP policy changes the default behavior of accessors to fit the recomendations found in Perl Best Practices.

CAVEATS ^

Always load Moose::Policy first.

You must put the following line of code:

  use Moose::Policy 'My::Policy';

before this line:

  use Moose;

This is because Moose::Policy must be given the opportunity to set the custom metaclass before Moose has set it's default metaclass. In fact, if you try to set a Moose::Policy and there is a meta method available, not only will kittens die, but your program will too.

Policies are class scoped

You must repeat the policy for each class you want to use it. It is not inherited. This may change in the future, probably it will be a Moose::Policy itself to allow Moose policies to be inherited.

THE POLICY ^

A Policy is set by passing Moose::Policy::import() a package name. This package is then queried for what metaclasses it should use. The possible metaclass values are:

metaclass

This defaults to Moose::Meta::Class.

attribute_metaclass
instance_metaclass
method_metaclass

For examples of what a Policy actually looks like see the examples in Moose::Policy:: and the test suite. More docs to come on this later (probably a cookbook or something).

METHODS ^

meta

FUTURE PLANS ^

As I said above, this is the first release and it is by no means feature complete. There are a number of thoughts on the future direction of this module. Here are some random thoughts on that, in no particular order.

Make set of policy roles

Roles are an excellent way to combine sets of behaviors together into one, and custom metaclasses are actually better composed by roles then by inheritence. The ideal situation is that this module will provide a set of roles which can be used to compose your meta-policy with relative ease.

BUGS ^

All complex software has bugs lurking in it, and this module is no exception. If you find a bug please either email me, or add the bug to cpan-RT.

AUTHOR ^

Stevan Little <stevan@iinteractive.com>

Eric Wilhelm

COPYRIGHT AND LICENSE ^

Copyright 2006-2007 by Infinity Interactive, Inc.

http://www.iinteractive.com

This library is free software; you can redistribute it and/or modify it under the same terms as Perl itself.

syntax highlighting: