Kevin Falcone > RT-Crypt-SMIME-0.23 > RT::Interface::Email::Auth::StrictSMIME

Download:
RT-Crypt-SMIME-0.23.tar.gz

Dependencies

Annotate this POD

CPAN RT

Open  1
View/Report Bugs
Source  

NAME ^

RT::Interface::Email::Auth::StrictSMIME - strict SMIME protection

DESCRIPTION ^

If message is not encrypted with SMIME standard then report error to sender and doesn't create or update ticket.

CONFIGURATION ^

Add this filter after standard RT's one and before any other. Configuration should be something like the following:

  @MailPlugins = (qw(Auth::MailFrom Auth::StrictSMIME Auth::SMIME));

As well you need template 'NotEncryptedMessage', this template is used to notify senders that their message was not recorded. When the template is called an object of the current ticket may be not available so you have to avoid any code in the template that doesn't check this fact. Use conditions if ( $TicketObj && $TicketObj-id ) {...}>. In general situation next template should work just fine:

  Subject: [ERROR] Couldn't process a message

  Hi, message you sent was not processed as it was not encrypted with
  SMIME encryption. Please, resubmit your request using encryption
  facility.

CAVEATS ^

This plugin should work normal with RT 3.6.3, but this version of RT has a little bit broken logic, so you may see undesirable side effects and probably wrong results. To fix issues we provide a patch you can find in patches dir within the tarball, changes in the patch are in the RT's repository and would be available with RT 3.6.4.

METHODS ^

GetCurrentUser

Returns a CurrentUser object. Also performs all the commands.

syntax highlighting: