Jerome Quelin > App-Magpie-2.007 > App::Magpie::App::Command::fixspec

Download:
App-Magpie-2.007.tar.gz

Dependencies

Annotate this POD

Website

CPAN RT

New  1
Open  0
View/Report Bugs
Module Version: 2.007   Source  

NAME ^

App::Magpie::App::Command::fixspec - update a spec file to match some policies

VERSION ^

version 2.007

SYNOPSIS ^

    $ eval $( magpie co -s perl-Foo-Bar )
    $ magpie fixspec

    # to get list of available options
    $ magpie help fixspec

DESCRIPTION ^

This command will update a spec file from a perl module package, and make sure it follows a list of various policies. It will also update the list of build prereqs, according to META.yml (or META.json) shipped with the distribution.

Note that this command will abort if it finds that the spec is too much outdated (eg, not using %perl_convert_version)

AUTHOR ^

Jerome Quelin <jquelin@gmail.com>

COPYRIGHT AND LICENSE ^

This software is copyright (c) 2011 by Jerome Quelin.

This is free software; you can redistribute it and/or modify it under the same terms as the Perl 5 programming language system itself.

syntax highlighting: