Julien Sobrier > Net-Google-SafeBrowsing2-1.08 > Net::Google::SafeBrowsing2::Postgres

Download:
Net-Google-SafeBrowsing2-1.08.tar.gz

Dependencies

Annotate this POD

CPAN RT

New  4
Open  2
View/Report Bugs
Module Version: 0.02   Source   Latest Release: Net-Google-SafeBrowsing2-1.11

NAME ^

Net::Google::SafeBrowsing2::Postgres - Postgres as back-end storage for the Google Safe Browsing v2 database

SYNOPSIS ^

  use Net::Google::SafeBrowsing2::Postgres;

  my $storage = Net::Google::SafeBrowsing2::Postgres->new(
    host     => '127.0.0.1',
    database => 'google_safe_browsing',
    username => $username,
    password => $password,
  );
  
  # ...

  $storage->close();

DESCRIPTION ^

This is an implementation of Net::Google::SafeBrowsing2::Storage using Postgres.

CONSTRUCTOR ^

new()

Create a Net::Google::SafeBrowsing2::Postgres object

  my $storage = Net::Google::SafeBrowsing2::Postgres->new(
      host     => '127.0.0.1', 
      database => 'google_safe_browsing', 
      username => $username,
      password => $password,
  );

Arguments

host

Specifies Postgres host name. Defaults to 127.0.0.1.

database

Specifies Postgres database name. Defaults to "google_safe_browsing".

username

Specifies the username for the Postgres connection. Required.

password

Specifies the password for the Postgres connection. Required.

keep_all

Optional. Set to 1 to keep old information (such as expiring full hashes) in the database. 0 (delete) by default.

PUBLIC FUNCTIONS ^

See Net::Google::SafeBrowsing2::Storage for a complete list of public functions.

close()

Cleanup old full hashes, and close the connection to the database.

  $storage->close();

SEE ALSO ^

See Net::Google::SafeBrowsing2 for handling Google Safe Browsing v2.

COPYRIGHT AND LICENSE ^

Copyright 2012 Nick Johnston, nickjohnstonsky@gmail.com. Based on Net::Google::SafeBrowsing2 by Julien Sobrier.

This library is free software; you can redistribute it and/or modify it under the same terms as Perl itself, either Perl version 5.8.8 or, at your option, any later version of Perl 5 you may have available.

syntax highlighting: