Lyo Kato > OAuth-Lite2-0.02_03 > OAuth::Lite2::Client::Agent::Strict

Download:
OAuth-Lite2-0.02_03.tar.gz

Annotate this POD

View/Report Bugs
Source   Latest Release: OAuth-Lite2-0.10

NAME ^

OAuth::Lite2::Client::Agent::Strict - Preset User Agent class for strict SSL

SYNOPSIS ^

    my $client = OAuth::Lite2::Client::WebApp->new(
        ..., # other params
        agent => OAuth::Lite2::Client::Agent::Strict->new(
            https_version => $https_version,
            ..., # https parameters
        ),
    );

DESCRIPTION ^

This module is one of preset user-agent class. This is useful when you want check the SSL strictly.

METHODS ^

request ($req)

Append to the behavior of parent class, this method verify the SSL, and if it fails, it throws the exception.

SEE ALSO ^

OAuth::Lite2::Client::Agent, OAuth::Lite2::Client::Agent::Dump

AUTHOR ^

Lyo Kato, lyo.kato _at_ gmail.com

COPYRIGHT AND LICENSE ^

This library is free software; you can redistribute it and/or modify it under the same terms as Perl itself, either Perl version 5.8.8 or, at your option, any later version of Perl 5 you may have available.

syntax highlighting: