Mike Jones > VOMS-Lite-0.20 > VOMS::Lite::Audit

Download:
VOMS-Lite-0.20.tar.gz

Dependencies

Annotate this POD

CPAN RT

Open  0
View/Report Bugs
Module Version: 0.20   Source  

NAME ^

VOMS::Lite::Audit - Perl extension for the creation of and parsing of DER encoded Audit Extension for the VOMS::Lite module.

SYNOPSIS ^

  use VOMS::Lite::Audit;


  my $DER = VOMS::Lite::Audit::Create('http://audit.endpoint.acme/');
  my $DER = VOMS::Lite::Audit::Create('http://audit.endpoint.acme/',1); #Set to critical (Not Generally Used/Recognised)

  my %Audit = %{ VOMS::Lite::Audit::Examine($DERencodedChunk) };
  print %Audit{'URL'}."\n";
  if ( %Audit{'critical'} ) {print "Is critical\n";}

  NB this is an experimental extension:
  There are known encoding issues that will change as the Auditing Service is developed.
  When this happens this module will need updating to match.

DESCRIPTION ^

  Creates or Examines an Audit extension for Proxy certificates

EXPORT

None.

SEE ALSO ^

This module was originally designed for the NGS SARoNGS service at The University of Manchester.

http://www.mc.manchester.ac.uk/projects/sarongs/ now http://www.rcs.manchester.ac.uk/projects/sarongs/

Globus Incubator project http://dev.globus.org/wiki/Incubator/Proxy-Audit

JISC funded project http://www.jisc.ac.uk/whatwedo/programmes/aim/pcai.aspx

AUTHOR ^

Mike Jones <mike.jones@manchester.ac.uk>

COPYRIGHT AND LICENSE ^

Copyright (C) 2010 by Mike Jones

This library is free software; you can redistribute it and/or modify it under the same terms as Perl itself, either Perl version 5.8.3 or, at your option, any later version of Perl 5 you may have available.

syntax highlighting: