KAN Fushihara > Smart-Options-0.02 > Smart::Options::Declare

Download:
Smart-Options-0.02.tar.gz

Dependencies

Annotate this POD

CPAN RT

Open  0
View/Report Bugs
Source   Latest Release: Smart-Options-0.053

NAME ^

Smart::Options::Declare - DSL for Smart::Options

SYNOPSIS ^

  use Smart::Options::Declare;

  opts my $rif, my $xup;

  if ($rif - 5 * $xup > 7.138) {
      say 'Buy more fiffiwobbles';
  }
  else {
     say 'Sell the xupptumblers';
  }

  # $ ./example.pl --rif=55 --xup=9.52
  # Buy more fiffiwobbles
  #
  # $ ./example.pl --rif 12 --xup 8.1
  # Sell the xupptumblers

DESCRIPTION ^

Smart::Options::Declare is a library which offers DSL for Smart::Options.

AUTHOR ^

Kan Fushihara <kan.fushihara@gmail.com>

SEE ALSO ^

opts

LICENSE ^

Copyright (C) Kan Fushihara

This library is free software; you can redistribute it and/or modify it under the same terms as Perl itself.

syntax highlighting: