Michael G Schwern > Say-Compat-0.01 > Say::Compat

Download:
Say-Compat-0.01.tar.gz

Dependencies

Annotate this POD

Website

View/Report Bugs
Module Version: 0.01   Source  

NAME ^

Say::Compat - Backwards compatibility wrapper for say()

SYNOPSIS ^

    use Say::Compat;

    say "Hello world!";
    say STDERR "Hello error!";

DESCRIPTION ^

This is a compatibility layer to allow Perl code to use say() without sacrificing backwards compatibility. Simply use the module in your code and it will do the right thing.

When used on a Perl before 5.10, it will load Perl6::Say.

When used on 5.10 or later it will load the built in say().

CAVEATS ^

Perl6::Say does not fully emulate all the syntax of the real say. Therefore, to avoid incompatibilities, you must code to its limitations. See the documentation for Perl6::Say for details.

Future versions may use a different module to emulate say, but they will strive to avoid

syntax highlighting: