無限健一 > Ruby-VersionManager > rvm.pl

Download:
Ruby-VersionManager-0.003019.tar.gz

Annotate this POD

CPAN RT

New  1
Open  0
View/Report Bugs
Source   Latest Release: Ruby-VersionManager-0.004004

NAME ^

rvm.pl

WARNING! ^

This is an unstable development release not ready for production!

VERSION ^

Version 0.003019

SYNOPSIS ^

rvm.pl will provide a subset of the bash rvm.

INSTALL RUBY ^

It is recommended to use Ruby::VersionManager with local::lib to avoid interference with possibly installed system ruby. Ruby::VersionManager comes with a script rvm.pl with following options.

version

Show the version of Ruby::VersionManager.

    rvm.pl version

list

List available ruby versions.

    rvm.pl list

updatedb

Update database of available ruby versions.

    rvm.pl updatedb

install

Install a ruby version. If no version is given the latest stable release will be installed. The program tries to guess the correct version from the provided string. It should at least match the major release. If you need to install a preview or rc version you will have to provide the full exact version.

Latest ruby

    rvm.pl install

Latest ruby-1.8

    rvm.pl install 1.8

Install preview

    rvm.pl install ruby-1.9.3-preview1

To use the Ruby::VersionManager source ruby_vmanager.rc.

    source ~/.ruby_vmanager/var/ruby_vmanager.rc

uninstall

Remove a ruby version and the source dir including the downloaded archive. You have to provide the full exact version of the ruby you want to remove as shown with list.

    rvm.pl uninstall ruby-1.9.3-preview1

If you uninstall your currently active ruby version you have to install/activate another version manually.

gem

Pass arguments to the gem command.

    rvm.pl gem install unicorn # installs unicorn

Additionally you can use reinstall to reinstall your complete gemset. With a file containing the output of 'gem list' you can reproduce gemsets.

    rvm.pl gem reinstall gem_list.txt # installs all gems in the list exactly as given

    rvm.pl gem reinstall # reinstalls all installed gems

gemset

Switch to another set of gems.

    rvm.pl gemset my_set

LIMITATIONS AND TODO ^

Currently Ruby::VersionManager is only running on Linux with bash installed. Better support of gemsets needs to be added.

AUTHOR ^

Mugen Kenichi, <mugen.kenichi at uninets.eu>

BUGS ^

Report bugs at:

SUPPORT ^

syntax highlighting: