The Perl Toolchain Summit needs more sponsors. If your company depends on Perl, please support this very important event.

NAME

AIX::LVM - Perl extension to handle AIX LVM Structure.

SYNOPSIS

  use AIX::LVM;

   my $lvm = AIX::LVM->new;

   my @volume_group = $lvm->get_logical_volume_group(); #List all the Volume groups present.

   my @pvs = $lvm->get_physical_volumes(); #List all the Physical volumes present.

   my @lvs = $lvm->get_logical_volumes(); #List all the Physical volumes present.

   #%vg_props consist of all the volume group properties in key=>value format.
   my %vg_props = $lvm->get_volume_group_properties("rootvg"); 

   #%lv_props consist of all the properties for logical volume "x" under volume group "rootvg";
   my %lv_props = $lvm->get_logical_volume_properties("rootvg","x");  

   my $lslv_l_cmd = $lvm->get_LV_logical_command("rootvg","x") #Equivalent to lslv -l x

   my $lslv_m_cmd = $lvm->get_LV_M_command("rootvg","x") #Equivalent to lslv -m x

DESCRIPTION

This Module is a Perl wrapper for AIX LVM and provides access to the properties of Volume groups, Logial Volumes, Physical Volumes, Physical Partitions. This provides access to LVM command equivalents.

METHODS

get_logical_volume_group();

Returns an array of volume groups present.

get_physical_volumes();

Returns an array of Physical volumes present.

get_logical_volumes();

Returns an array of Logical volumes present.

get_volume_group_properties("rootvg")

Returns a hash of properties for volume group "rootvg"

get_logical_volume_properties("rootvg","hd5")

Returns a hash of properties for logical volume "hd5" present under volume group "rootvg"

get_physical_volume_properties("rootvg","hdisk0")

Returns a hash of properties for physical volume "hdisk0" present under volume group "rootvg"

get_LV_logical_command("rootvg","hd5")

Returns output as scalar for command equivalent of lslv -l hd5

get_LV_ M_command("rootvg","hd5")

Returns output as scalar for command equivalent of lslv -m hd5

get_PV_PP_command("rootvg","hdisk0")

Returns output as scalar for command equivalent of lspv -p hd5

get_PV_LV_command("rootvg","hdisk0")

Returns output as scalar for command equivalent of lspv -l hd5

CAVEATS

Needed to be executed as root user.

VG IDENTIFIER property for physical volume doesn't have proper format i.e Missing : at the end. This may differ for different versions of AIX.

SEE ALSO

IO::Select

IPC::Open3

AUTHOR

Murugesan Kandasamy <Murugesan.Kandasamy@gmail.com>

COPYRIGHT AND LICENSE

Copyright (C) 2010 by Murugesan Kandasamy

This library is free software; you can redistribute it and/or modify it under the same terms as Perl itself, either Perl version 5.6.1 or, at your option, any later version of Perl 5 you may have available.

1 POD Error

The following errors were encountered while parsing the POD:

Around line 430:

You forgot a '=back' before '=head1'