View on
MetaCPAN
Olaf Alders > WebService-PayPal-PaymentsAdvanced-0.000008 > WebService::PayPal::PaymentsAdvanced::Error::Authentication

Download:
WebService-PayPal-PaymentsAdvanced-0.000008.tar.gz

Dependencies

Annotate this POD

Website

View/Report Bugs
Module Version: 0.000008   Source   Latest Release: WebService-PayPal-PaymentsAdvanced-0.000023

NAME ^

WebService::PayPal::PaymentsAdvanced::Error::Authentication - A Payments Advanced authentication error

VERSION ^

version 0.000008

SYNOPSIS ^

    use Try::Tiny;
    use WebService::PayPal::PaymentsAdvanced;
    my $payments = WebService::PayPal::PaymentsAdvanced->new(...);

    try {
        $payments->create_secure_token(...);
    }
    catch {
        die $_ unless blessed $_;
        if (
            $_->isa(
                'WebService::PayPal::PaymentsAdvanced::Error::Authentication')
            ) {
            log_auth_error(
                message => $_->message,
                params  => $_->params,
            );
        }

        # handle other exceptions
    };

DESCRIPTION ^

This class represents an authentication error returned by PayPal. It extends Throwable::Error and adds one attribute of its own.

METHODS ^

The $error-message()>, and $error-stack_trace()> methods are inherited from Throwable::Error.

params

Returns a HashRef of params which was received from to PayPal.

AUTHOR ^

Olaf Alders <olaf@wundercounter.com>

COPYRIGHT AND LICENSE ^

This software is Copyright (c) 2015 by MaxMind, Inc..

This is free software, licensed under:

  The Artistic License 2.0 (GPL Compatible)
syntax highlighting: