Robin Berjon > AxKit-Plugin-DisableXSLTParams-0.01 > AxKit::Plugin::DisableXSLTParams

Download:
AxKit-Plugin-DisableXSLTParams-0.01.tar.gz

Dependencies

Annotate this POD

View/Report Bugs
Module Version: 0.01   Source  

NAME ^

AxKit::Plugin::DisableXSLTParams - Disable XSLT Params

SYNOPSIS ^

  # in your Apache conf
  AxAddPlugin  AxKit::Plugin::DisableXSLTParams

DESCRIPTION ^

Under normal circumstances, CGI params are passed on top the XSLT processor. While this can be wanted, it can also have undesirable effects. Some of those may match variable or other param names that you use in your XSLT stylesheet, and having them forced upon you by CGI params can lead to hard to locate bugs.

All you need to do to make them go away is to add this module to your conf.

The patch that allows this module to work should have been in AxKit 1.5 but unfortunately it somehow slipped. Currently you'll need the CVS version of AxKit (see http://axkit.org/ for details on how to get it) or wait until 1.5.1 or 1.6.

AUTHOR ^

Robin Berjon, robin@knowscape.com

COPYRIGHT ^

Copyright (c) 2001,2002 Robin Berjon. All rights reserved. This program is free software; you can redistribute it and/or modify it under the same terms as Perl itself.

SEE ALSO ^

AxKit

syntax highlighting: