Ricardo SIGNES > Dist-Zilla-Plugin-CheckPrereqsIndexed-0.012 > Dist::Zilla::Plugin::CheckPrereqsIndexed

Download:
Dist-Zilla-Plugin-CheckPrereqsIndexed-0.012.tar.gz

Dependencies

Annotate this POD

Website

View/Report Bugs
Module Version: 0.012   Source   Latest Release: Dist-Zilla-Plugin-CheckPrereqsIndexed-0.013

NAME ^

Dist::Zilla::Plugin::CheckPrereqsIndexed - prevent a release if you have prereqs not found on CPAN

VERSION ^

version 0.012

OVERVIEW ^

Sometimes, AutoPrereqs is a little overzealous and finds a prereq that you wrote inline or have in your ./t directory. Although AutoPrereqs should grow more accurate over time, and avoid these mistakes, it's not perfect right now. CheckPrereqsIndexed will check every required package against the CPAN index to ensure that they're all real, installable packages.

If any are unknown, it will prompt the user to continue or abort.

At present, CheckPrereqsIndexed queries CPANIDX, but this behavior is likely to change or become pluggable in the future. In the meantime, this makes releasing while offline impossible... but it was anyway, right?

ATTRIBUTES ^

skips

This is an arrayref of regular expressions. Any module names matching any of these regex will not be checked. This should only be necessary if you have a prerequisite that is not available on CPAN (because it's distributed in some other way).

AUTHOR ^

Ricardo Signes <rjbs@cpan.org>

COPYRIGHT AND LICENSE ^

This software is copyright (c) 2011 by Ricardo Signes.

This is free software; you can redistribute it and/or modify it under the same terms as the Perl 5 programming language system itself.

syntax highlighting: