Salvador Fandiño García > Net-OpenSSH-Compat-0.06 > Net::OpenSSH::Compat

Download:
Net-OpenSSH-Compat-0.06.tar.gz

Dependencies

Annotate this POD

CPAN RT

Open  0
View/Report Bugs
Module Version: 0.06   Source  

NAME ^

Net::OpenSSH::Compat - Compatibility modules for Net::OpenSSH

SYNOPSIS ^

  use Net::OpenSSH::Compat 'Net::SSH2';
  use Net::OpenSSH::Compat 'Net::SSH::Perl';

DESCRIPTION ^

This package contains a set of adapter modules that run on top of Net::OpenSSH providing the APIs of other SSH modules available from CPAN.

Currently, there are adapters available for Net::SSH2 and Net::SSH::Perl. Adapters for Net::SSH and Net::SFTP are planned... maybe also for Net::SCP and Net::SCP::Expect if somebody request them.

BUGS AND SUPPORT ^

This is a work in progress.

If you find any bug fill a report at the CPAN RT bugtracker (https://rt.cpan.org/Ticket/Create.html?Queue=Net-OpenSSH-Compat) or just send me an e-mail with the details.

Git repository

The source code repository is at https://github.com/salva/p5-Net-OpenSSH-Compat.

My wishlist

If you like this module and you're feeling generous, take a look at my Amazon Wish List: http://amzn.com/w/1WU1P6IR5QZ42

Also consider contributing to the OpenSSH project this module builds upon: http://www.openssh.org/donations.html.

SEE ALSO ^

Net::OpenSSH, Net::OpenSSH::Compat::SSH2, Net::OpenSSH::Compat::Perl.

COPYRIGHT AND LICENSE ^

Copyright (C) 2011 by Salvador Fandino (sfandino@yahoo.com)

This library is free software; you can redistribute it and/or modify it under the same terms as Perl itself, either Perl version 5.10.1 or, at your option, any later version of Perl 5 you may have available.

syntax highlighting: