Sawyer X > Dancer-Plugin-Authorize-1.110720 > Dancer::Plugin::Authorize::Credentials

Download:
Dancer-Plugin-Authorize-1.110720.tar.gz

Dependencies

Annotate this POD

View/Report Bugs
Module Version: 1.110720   Source  

NAME ^

Dancer::Plugin::Authorize::Credentials - Dancer::Plugin::Authorize Credentials base class and guide!

VERSION ^

version 1.110720

SYNOPSIS ^

    package Dancer::Plugin::Authorize::Credentials::MyAuthorizationClass;
    use base 'Dancer::Plugin::Authorize::Credentials';
    
    # every authentication class must have an authorize routine
    sub authorize {
        my ($self, $options, @arguments) = @_;
        my ($login, $password) = @arguments;
        ...
    }
    
    1;

DESCRIPTION ^

The Dancer::Plugin::Authorize::Credentials class should be used as a base class in your custom credentials/authorization classes. When used as a base class, this class provides instantiation and simple error handling for your authorization classes.

AUTHOR ^

  Al Newkirk <awncorp@cpan.org>

COPYRIGHT AND LICENSE ^

This software is copyright (c) 2010 by awncorp.

This is free software; you can redistribute it and/or modify it under the same terms as the Perl 5 programming language system itself.

syntax highlighting: