Sawyer X > Dancer2-0.08 > Dancer2::ModuleLoader

Download:
Dancer2-0.08.tar.gz

Dependencies

Annotate this POD

Website

View/Report Bugs
Module Version: 0.08   Source  

NAME ^

Dancer2::ModuleLoader - Dynamic module loading helpers for Dancer2 core components

VERSION ^

version 0.08

DESCRIPTION ^

Sometimes in Dancer2 core we need to use modules, but we don't want to declare them all in advance in compile-time. These could be because the specific modules provide extra features which depend on code that isn't (and shouldn't) be in core, or perhaps because we only want these components loaded in lazy style, saving loading time a bit.

To do such things takes a bit of code for localizing $@ and evaling. That code has been refactored into this module to help Dancer2 core developers.

Please only use this for Dancer2 core modules. If you're writing an external Dancer2 module (Dancer2::Template::Tiny, Dancer2::Session::Cookie, etc.), please simply "use ModuleYouNeed" in your code and don't use this module.

WARNING, all the following methods are CLASS methods.

METHODS ^

load

Runs a "use ModuleYouNeed".

    use Dancer2::ModuleLoader;
    ...
    Dancer2::ModuleLoader->load('Something')
        or die "Couldn't load Something\n";

    # load version 5.0 or more
    Dancer2::ModuleLoader->load('Something', '5.0')
        or die "Couldn't load Something\n";

    # load version 5.0 or more
    my ($res, $error) = Dancer2::ModuleLoader->load('Something', '5.0');
    $res or die "Couldn't load Something : '$error'\n";

Takes in arguments the module name, and optionally the minimum version number required.

In scalar context, returns 1 if successful, 0 if not. In list context, returns 1 if successful, (0, "error message") if not.

If you need to give arguments to the loading module, please use the method load_with_params

require

Runs a "require ModuleYouNeed".

    use Dancer2::ModuleLoader;
    ...
    Dancer2::ModuleLoader->require('Something')
        or die "Couldn't require Something\n";
    my ($res, $error) = Dancer2::ModuleLoader->require('Something');
    $res or die "Couldn't require Something : '$error'\n";

If you are unsure what you need (require or load), learn the differences between require and use.

Takes in arguments the module name, and an optional version.

In scalar context, returns 1 if successful, 0 if not. In list context, returns 1 if successful, (0, "error message") if not.

load_with_params

Runs a "use ModuleYouNeed qw(param1 param2 ...)".

    use Dancer2::ModuleLoader;
    ...
    Dancer2::ModuleLoader->load('Something', qw(param1 param2) )
        or die "Couldn't load Something\n";

    my ($res, $error) = Dancer2::ModuleLoader->load('Something', @params);
    $res or die "Couldn't load Something : '$error'\n";

Takes in arguments the module name, and optionally parameters to pass to the import internal method.

In scalar context, returns 1 if successful, 0 if not. In list context, returns 1 if successful, (0, "error message") if not.

use_lib

Runs a "use lib qw(path1 path2)" at run time instead of compile time.

    use Dancer2::ModuleLoader;
    ...
    Dancer2::ModuleLoader->use_lib('path1', @other_paths)
        or die "Couldn't perform use lib\n";

    my ($res, $error) = Dancer2::ModuleLoader->use_lib('path1', @other_paths);
    $res or die "Couldn't perform use lib : '$error'\n";

Takes in arguments a list of path to be prepended to @INC, in a similar way than use lib. However, this is performed at run time, so the list of paths can be generated and dynamic.

In scalar context, returns 1 if successful, 0 if not. In list context, returns 1 if successful, (0, "error message") if not.

AUTHOR ^

Dancer Core Developers

COPYRIGHT AND LICENSE ^

This software is copyright (c) 2013 by Alexis Sukrieh.

This is free software; you can redistribute it and/or modify it under the same terms as the Perl 5 programming language system itself.

syntax highlighting: